Scheduled for August 22, 2025 at 11:30 AM – 2:00 PM
Affects
SkyFi
Under maintenance from 11:30 AM to 2:00 PM
SkyFi North
Under maintenance from 11:30 AM to 2:00 PM
Updates
Completed
August 22, 2025 at 2:00 PM
Completed
August 22, 2025 at 2:00 PM
Maintenance has completed successfully
In progress
August 22, 2025 at 11:30 AM
In progress
August 22, 2025 at 11:30 AM
Maintenance is now in progress
Planned
August 22, 2025 at 11:30 AM
Planned
August 22, 2025 at 11:30 AM
Network Maintenance Notice
When: Friday, August 22, 2025 — 4:30 AM to 7:00 AM
Purpose: Relocating SkyLink equipment at the Slide Ridge tower.
Affected: All SkyLink customers served by the Slide Ridge tower (near Chelan, WA)
A single extended outage, potentially lasting an hour or longer, will occur between 4:30 AM and 6:00 AM while equipment is moved. After this work, additional interruptions may occur through the remainder of the maintenance window, but they are expected to be brief and minimized.