Scheduled for September 04, 2025 at 6:00 AM – 1:00 PM
Affects
PUD Fiber
Under maintenance from 6:00 AM to 1:00 PM
Chelan County Fiber
Under maintenance from 6:00 AM to 1:00 PM
Updates
Completed
September 04, 2025 at 1:00 PM
Completed
September 04, 2025 at 1:00 PM
Maintenance has completed successfully
In progress
September 04, 2025 at 6:00 AM
In progress
September 04, 2025 at 6:00 AM
Maintenance is now in progress
Planned
September 04, 2025 at 6:00 AM
Planned
September 04, 2025 at 6:00 AM
Next Wednesday, the 3rd, the Chelan PUD has scheduled maintenance from 11:00pm to 6:00am the 4th, in the Welch Ave and Springwater area of Wenatchee. Please see the information from the PUD below for further details.
LCCPUD NETWORKS MAINTENANCE NOTICE L
TITLE: Welch Ave Cable Damage
LOCATION: Western Node (Welch Ave)
START TIME: 9/3/2025 11:00 PM
END TIME: 9/4/2025 6:00 AM
Services Affected: All Services
Purpose: Fiber cable serving FDT-034 was damaged causing degraded TV services.