Chelan PUD Emergency Maintenance Manson 3/12/26 10pm- 3/13/26 TBD
Completed
Scheduled for March 13, 2026 at 5:00 AM – March 16, 2026 at 3:40 PM
Affects
PUD Fiber
Under maintenance from 5:00 AM to 3:40 PM
Chelan County Fiber
Under maintenance from 5:00 AM to 3:40 PM
Updates
Completed
March 16, 2026 at 3:40 PM
Completed
March 16, 2026 at 3:40 PM
Maintenance has completed successfully.
In progress
March 13, 2026 at 5:00 AM
In progress
March 13, 2026 at 5:00 AM
Maintenance is now in progress
Planned
March 13, 2026 at 5:00 AM
Planned
March 13, 2026 at 5:00 AM
Chelan PUD Emergency Maintenance
TITLE: Windstorm Damage
LOCATION: Manson
START TIME: 3/12/2026 : 10:00 PM
END TIME: 3/13/2026 : TBD
Services Affected: All Services
Purpose: This outage is due to storm damage. Once electrical crews have finished their work, then our fiber crews will be able to start making repairs. Fiber repair will start this evening and will conclude tomorrow.