LocalTel - CCPUD NETWORKS EMERGENCY MAINTENANCE NOTICE - Repair Rodent Damage - 3/24/2026 3:30 PM - 3/25/2026 1:00 AM - Service Affecting – Incident details

All systems operational

CCPUD NETWORKS EMERGENCY MAINTENANCE NOTICE - Repair Rodent Damage - 3/24/2026 3:30 PM - 3/25/2026 1:00 AM - Service Affecting

Resolved
Major outage
Started 5 days agoLasted about 16 hours

Affected

PUD Fiber

Major outage from 10:57 PM to 2:45 PM

Chelan County Fiber

Major outage from 10:57 PM to 2:45 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Identified
    Identified

    CCPUD NETWORKS EMERGENCY MAINTENANCE NOTICE - Repair Rodent Damage - 3/24/2026 3:30 PM - 3/25/2026 1:00 AM - Service Affecting

    TITLE: Repair Rodent Damage

    LOCATION: Wenatchee

    START TIME: 3/24/2026 3:30 PM

    END TIME: 3/25/2026 1:00 AM

    Services Affected: All Services

    Purpose: This outage is required to repair rodent damage on a Fiber cable.