LocalTel - Grant Fiber Incident – Incident details
Grant County Fiber under maintenance
Grant Fiber Incident
Resolved
Partial outage
Started 5 months agoLasted 1 day
Affected
PUD Fiber
Partial outage from 6:06 PM to 7:03 PM
Grant County Fiber
Partial outage from 6:06 PM to 7:03 PM
Updates
Resolved
Resolved
This incident has been resolved.
Identified
Identified
Fiber service remains out to customers north of Soap Lake after a tree-trimming crew accidentally cut a fiber-optic cable. Repair is underway but time consuming. Service will likely be out until 8 p.m.
Investigating
Investigating
Customers in your area may be experiencing service issues. We’re urgently working on a fix & will update you when service is restored.
Fiber issue effecting Coulee City, Grand Coulee, and Electric City.