Chelan PUD Emergency Maintenance Western Node 8/20 11pm-8/21 7am
Completed
Scheduled for August 21, 2025 at 6:00 AM – 2:00 PM
Affects
PUD Fiber
Under maintenance from 6:00 AM to 2:00 PM
Chelan County Fiber
Under maintenance from 6:00 AM to 2:00 PM
Updates
Completed
August 21, 2025 at 2:00 PM
Completed
August 21, 2025 at 2:00 PM
Maintenance has completed successfully
In progress
August 21, 2025 at 6:00 AM
In progress
August 21, 2025 at 6:00 AM
Maintenance is now in progress
Planned
August 21, 2025 at 6:00 AM
Planned
August 21, 2025 at 6:00 AM
Tonight, Wednesday, the 20th, the Chelan PUD has scheduled Emergency maintenance from 11:00pm to 7:00 am, the 21st, in the Western Node area of Wenatchee. Please see the information from the PUD below for further details.
LCCPUD NETWORKS EMERGENCY MAINTENANCE NOTICE L
TITLE: Low optical signal
LOCATION: Western Node
START TIME: 8/20/2025 11:00 PM
END TIME: 8/21/2025 7:00 AM
Services Affected: All Services
Purpose: Technicians will be disconnecting the fiber for FDT-034 to troubleshoot a low optical signal from the PON. Outage time should be about 15min during this window.