Chelan PUD South Pedestrian Bridge Maintenance 10/23 11pm-10/24 6am.
Completed
Scheduled for October 24, 2025 at 6:00 AM – 1:00 PM
Affects
PUD Fiber
Under maintenance from 6:00 AM to 1:00 PM
Chelan County Fiber
Under maintenance from 6:00 AM to 1:00 PM
Updates
Completedsafojaskfaokf
October 24, 2025 at 1:00 PM
Completed
October 24, 2025 at 1:00 PM
Maintenance has completed successfully
In progresssafojaskfaokf
October 24, 2025 at 6:00 AM
In progress
October 24, 2025 at 6:00 AM
Maintenance is now in progress
Updatesafojaskfaokf
October 24, 2025 at 6:00 AM
Update
October 24, 2025 at 6:00 AM
Thursday, the 16th, the Chelan PUD has scheduled maintenance from 11:00pm to 6:00am on the 17th, the N Worthen Area of Wenatchee. Please see the information from the PUD below for further details.
LCCPUD NETWORKS MAINTENANCE NOTICE L
TITLE: South Pedestrian Bridge Maintenance
LOCATION: Wenatchee
START TIME: 10/16/2025 11:00 PM
END TIME: 10/17/2025 6:00 AM
Services Affected: All Services
Purpose: Construction near the South Pedestrian Bridge requires that we move some fiber optic cables.
Plannedsafojaskfaokf
October 14, 2025 at 9:42 PM
Planned
October 14, 2025 at 9:42 PM
This maintenance has been rescheduled to the following date.