Scheduled for November 25, 2025 at 5:00 PM – 11:00 PM
Affects
PUD Fiber
Under maintenance from 5:00 PM to 11:00 PM
Chelan County Fiber
Under maintenance from 5:00 PM to 11:00 PM
Updates
Completed
November 25, 2025 at 11:00 PM
Completed
November 25, 2025 at 11:00 PM
Maintenance has completed successfully
In progress
November 25, 2025 at 5:00 PM
In progress
November 25, 2025 at 5:00 PM
Maintenance is now in progress
Planned
November 25, 2025 at 5:00 PM
Planned
November 25, 2025 at 5:00 PM
Tuesday, the 25th, the Chelan PUD has scheduled maintenance from 9:00am to 3:00pm in the Woodin Ave and Lakeshore PL areas of Chelan . Please see the information from the PUD below for further details.
CCPUD NETWORKS MAINTENANCE NOTICE
TITLE: Woodin Ave FM
LOCATION: Chelan
START TIME: 11/25/2025 : 9:00 AM
END TIME: 11/25/2025 : 3:00 PM
Services Affected: All Services
Purpose: This outage is to finish permanent fixes to previously damaged fiber optic cables in the area.