LocalTel - Chelan County PUD fiber break - Eagle Creek and Surrounding area (Leavenworth WA) – Incident details

All systems operational

Chelan County PUD fiber break - Eagle Creek and Surrounding area (Leavenworth WA)

Resolved
Under maintenance
Started 11 days agoLasted 2 days

Affected

PUD Fiber

Major outage from 11:00 PM to 6:20 PM, Operational from 5:17 PM to 6:20 PM

Chelan County Fiber

Major outage from 11:00 PM to 6:20 PM, Operational from 5:17 PM to 6:20 PM

Updates
  • Resolved
    UTC
    Resolved

    Chelan County PUD has made the repair to the fiber optic line and customers are back online. If you're still having issues please contact Technical Support at 509-888-5700 6am - midnight 7 days a week to help get your service restored.. (RESOLVED)

  • Monitoring
    UTC
    Monitoring
    We implemented a fix and are currently monitoring the result.
  • Identified
    UTC
    Identified

    There has been a fiber optic break up the Eagle Creak area in Leavenworth Washington. This will cause disruptions to all fiber internet, TV and telephone connections. The estimated time to repair the fiber optic cable is 5pm 9/12/26. If you live in or around that area you will most likely be impacted by that outage.